Error: Non-nullable column cannot be updated to Null (NAM)
Article Number: 303 | Rating: Unrated | Last Updated: Sat, Sep 29, 2012 at 6:13 AM
Purpose:
To explain how to resolve the Counterpoint import error, "Error: Non-nullable column cannot be updated to Null (NAM)."
Solution:
This error may occur when attempting to import a file from NRO.
Note: It's advisable to never change the name format in Counterpoint, after a store goes live.
This error message means that NRO is configured to use
Combined first/last name
for the customer's name format, whereas the template customer record in Counterpoint has a value of
Person
for Name type.
Solution:
Change the value on the template customer record of the NRO setting to be consistent with each other.
Go to
Customers / Customers
and select the template customer. Change the Name type of Business or Person.
Go to
Setup/Ecommerce/Control
and open the Customers tab. For the Name format, choose the setting that matches the default ecommerce customer.
Go to CPOnline Store Management. Under
Manage Customers / Customer Defaults
change the name format to match the setting of the default ecommerce customer and the ecommerce control file.
Business = Combined
Person = Separate
To separate the first and last name of the customer:
CPSQL > Customers > Customers
: open the template customer and set the name type to Person.
CPSQL > Setup > Ecommerce > Control > Customers tab
: set 'Set Customer Name from' setting to Customer Name.
To combine the first and last name of the customer:
CPSQL > Customers > Customers
: open the template customer and set the name type to Business.
CPSQL > Setup > Ecommerce > Control > Customers tab
: set 'Set Customer Name from' setting to Company Name.