If ADT isn't running, then one of these scenarios might be the problem:
ADT can't run because there are no free CounterPoint logins (meaning that the maximum number of allowed users have logged into CounterPoint and there are no more licenses available for the ADT user to log in and perform an ecommerce import or ecommerce publish).
The computer running the ADT task is not accessible (meaning the computer has either been turned off or the Window's user ID can't log into the computer running ADT. This occurs when the password has been changed).
The drawer for ecommerce isn't activated and the ADT user isn't allowed to auto-activate the drawer.
The ADT user login's password has changed as a result of the CounterPoint 90 day password change requirement. **Note: Enforcing account password changes every 90 days is fundamental to PCI compliancy.
Finding the ADT Log File
When the ADT task executes, CounterPoint creates an ADT log that is helpful in determining what is happening when ADT runs or fails. The log file is named ADT.log. The file exists in a CounterPoint folder named Actions. The steps below will help you find the ADT.log file:
Instructions NCR Counterpoint 8.3.9:
In Counterpoint, go to
Setup
>
Ecommerce
>
Control
.
On the main tab of the ecommerce control file is a field labeled "Ecommerce Directory." If you click the hyperlink in that field, it will open the CPOnline folder.
After clicking that hyperlink, use the Up button in your Windows toolbar to move up two directory levels. The "Up" button looks like a manilla folder with a superimposed green arrow. Clicking it one time will move you up one directory level. Be sure to click the button twice to move up two directory levels. Also, the Up command can be found under the View Menu > Go to > Up one level. Perform this action twice.
Upon following step three, you'll see a folder named "Configuration." Open that folder.
Upon opening the Configuration folder, you'll see a folder named "Actions." Open that folder to find the ADT.log file.
Instructions for NCR Counterpoint 8.4.x and above:
In Counterpoint, go to
Setup
>
Ecommerce
>
Control
.
On the main tab of the ecommerce control file is a field labeled "Ecommerce Directory." If you click the hyperlink in that field, it will open the CPOnline folder.
After clicking that hyperlink, use the Up button in your Windows toolbar to move up one directory level. The "Up" button looks like a manilla folder with a superimposed green arrow. Clicking it one time will move you up onedirectory level. Also, the Up command can be found under the View Menu > Go to > Up one level. Move up 4 directory levels (until you get to CPSQL.1).
Open Logs > CPLogs.
The ADT log will display your Counterpoint company name followed by _ADT.log.
Resolving Errors
Issue 1, No Counterpoint Logins
The easiest resolution for this problem is to have someone who is logged into Countepoint and may not need to be, to log out. In the log run, if this error continues to happen, you may need to purchase another user license for ADT to be able to run. (Contact your Counterpoint Partner to purchase additional user licenses.)
Issue 2, Computer not Accessible
This will happen if either the server running Counterpoint is turned off, The password has changed and not been updated in ADT scheduled tasks, or the password has expired. To corret this error, ensure the server is turned on first. If this is not the case, the next step would be to try and log into the server using the credentials that ADT is running. To find the username that ADT is using you can use the ADT Scheduler.
On your server, browse to
Start / Programs / Counterpoint SQL / Utilities / System Configuration Utility
.
Click
Scheduled Tasks
.
Select the
Automated Data Transfer
task and choose
Edit
.
The
Run As
field will display the
username
that Counterpoint is logging into Windows with.
Try logging into your Windows server with this Username and Password. If you do not know the password for this user or if the password does not work, you will need to update the password on your Windows Server. Once this is done. follow steps 1 - 4 above to correct the password in the Automated Data Transfer window.
*Note, ADT will continue to try to log into Counterpoint, even though the Counterpoint password may have expired. Once the password is reset in Counterpoint and update the task itself to use the new Password, ADT may continue to not run because the Counterpoint user ID will have been disabled due to too many failed login attempts.
Issue 3, Drawer not Active or no permission to auto activate
These errors happen when the ADT service cannot activate the drawer used for ecommerce orders. Please contact your NCR Counterpoint PArtner for assistance with this error. The drawer should be set to auto activate for the ADT user.
Issue 4, Incorrect ADT Password
This indicates that the password used by ADT to log into Counterpoint has expired or incorrect. Counterpoint for PCI compliances requires your user passwords to be reset every 90 days. Once you have updated your password:
On your server, browse to
Start / Programs / Counterpoint SQL / Utilities / System Configuration Utility
.
Click
Scheduled Tasks
.
Select the
Automated Data Transfer
task and choose
Edit
.
Switch to the
Parameters tab
.
Update the
CP Password
field with the update
password
and click
OK
.